Как в 1С 7.7 сделать обмен на базе FTP

Публикация № 1234874

Разработка - Системная интеграция - Файловые протоколы обмена, FTP

7.7 FTP обмен данными

Выгрузка данных на FTP на примере в конфигурации Штрих-М Кассир 1.10.

Как сделать на базе 1с.77 обмен по ftp

Рассмотрим пример на базе конфигурации Штрих-М кассир 1.хх:

 

  1. Настройка FTP

Во первых для того чтобы сделать обмен по FTP, необходима компонента которая способна работать по данному протоколу, мы используем “DialMail.dll”.

В процедуре “ПриНачалеРаботыСистемы” определим следующее, каталог в который будут сохраняться файлы и отправляться на FTP сервер:

             

КаталогFTP= КаталогИБ()+"FTP";

Время когда была произведена последняя отправка  на FTP сервер:            

Константа.УдачноеВремяОтправки            = ТекущееВремя();

                Константа.РаботаПоИнтервалу_2 = 0;

Инициализация компоненты DialMail:

                Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "DialMail.dll")=0 Тогда

                               Сообщить("Не удалось обнаружить компоненту DialMail.dll!");

                КонецЕсли;

                Попытка

                               FTP = СоздатьОбъект("AddIn.FTP");

                               FTP.ИмяЛогФайла = КаталогИБ() + "dialmail_ftp.log";

                               FTP.ВестиЛогФайл = 1;

                               FTP.ВестиТехническийЛогФайл = 1;

                               FTP.NewRFC = 0;

                               Сообщить(FTP.ВерсияОбъектаСтр);

                Исключение

                               Сообщить("Не удалось создать объект из компоненты DialMail.dll!");

                КонецПопытки;

               

 

  1. Настройка FTP

Во первых для того чтобы сделать обмен по FTP, нужно сделать настройки

Для обработки «Настройка» создадим вкладку «РаботаСFTP»

Добавим реквизиты:

- ОбменПоFTP(флаг использовать обмен по FTP или нет),

- ИмяСервераФТП(Имя сервера FTP для связи),

- ИмяПользователяФТП(Имя пользователя FTP для связи),

- ПарольПользователяФТП (Пароль пользователя FTP для связи),

- ПортФТП (Порт FTP для связи),

- ПассивныйРежимФТП (Пассивный или нет режим FTP для связи, через перечисление),

- Интервал1ФТП(Период через который будут отправляться файлы)

- Интервал2ФТП(Период через который система будет проверять связь в случае ее отстутствия).

В модуле обработки создадим процедуру “ВыборFTP”, заполнение полей вкладки из констант

Процедура ВыборFTP() 
	//Обмен данными по ФТП
	ИмяСервераФТП         = Константа.ИмяСервераФТП;
	ИмяПользователяФТП    = Константа.ИмяПользователяФТП;
	ПарольПользователяФТП = Константа.ПарольПользователяФТП; 
	ПортФТП               = Константа.ПортФТП;
	ПассивныйРежимФТП     = Константа.ПассивныйРежимФТП;
	Интервал1ФТП		  = Константа.Интервал1ФТП;
	Интервал2ФТП 		  = Константа.Интервал2ФТП; 
	ОбменПоFTP			  = Константа.ОбменПоFTP;
	Если ПортФТП < 1 Тогда
		ПортФТП = 21;
	КонецЕсли;	
КонецПроцедуры

В процедуре “ПриВыбореЗакладки” дополним следующим кодом, для отображения вкладки и заполнения параметров вкладки:

ИначеЕсли ЗначениеЗакладки=11 Тогда     
		Форма.ИспользоватьСлой("РаботаСFTP",1);
		ВыборFTP();

В конце модуля добавим код чтобы вкладка была в списке вкладок:

Форма.Закладки.ДобавитьЗначение(11,"Настройка FTP"); 

И конечно же для запоминания изменений по параметрам FTP в процедуру “Выполнить” добавим код:

Константа.ИмяСервераФТП         = СокрЛП(ИмяСервераФТП);
	Константа.ИмяПользователяФТП    = СокрЛП(ИмяПользователяФТП);
	Константа.ПарольПользователяФТП = ПарольПользователяФТП; 
	Константа.ПортФТП               = ПортФТП;
	Константа.ПассивныйРежимФТП     = ПассивныйРежимФТП;   
	Константа.Интервал1ФТП			= Интервал1ФТП;
	Константа.Интервал2ФТП			= Интервал2ФТП;  
	Константа.ОбменПоFTP			= ОбменПоFTP;

        

  1. Режим обмена FTP

Определим периодический обмен в процедуре “Таймер”, добавив код

Если (Константа.ОбменПоFTP>0) И (Константа.РаботаПоИнтервалу_2 >0) Тогда 
		Если ПрошелИнтервал1()=1 Тогда 
			Для й=1 по 3 Цикл
				FTPThreads[й] = "";
				ИДПотока[й] = 0;
				СостояниеПотока[й] = "";
			КонецЦикла;
			//Поиск не отправленных Файлов 
			ФС.УстТекКаталог(КаталогFTP);
			ИмяФайла = ФС.НайтиПервыйФайл("*.*");    
			Пока 1=1 Цикл                            
				ИмяФайла = ФС.НайтиСледующийФайл(); 
				Если ПустаяСтрока(ИмяФайла)=1 Тогда
					Прервать;
				КонецЕсли;
				Если (ИмяФайла=".") или (ИмяФайла="..") Тогда
					Продолжить;
				КонецЕсли;
				//-2-  Отправить по FTP  
				Если (ПодключитьсяКFTP()>0) Тогда
					Если ВыгрузитьНаFTP(КаталогFTP+"\"+ИмяФайла,ИмяФайла)=0 Тогда
						//включение интервала 2 
						Константа.РаботаПоИнтервалу_2 = 1;
						Прервать;
					Иначе
						Константа.УдачноеВремяОтправки	= ТекущееВремя();
						Константа.РаботаПоИнтервалу_2 = 0;	
						//Переименовать!
						ИмяКуда = СтрЗаменить(КаталогFTP+"\"+ИмяФайла,"PROD","OTPR");
						ФС.ПереименоватьФайл(КаталогFTP+"\"+ИмяФайла,ИмяКуда,1);
					КонецЕсли;
				КонецЕсли;
			КонецЦикла; 
			ОтключитьсяОтFTP(); 
			Константа.УдачноеВремяОтправки	= ТекущееВремя();
		КонецЕсли;
	КонецЕсли;

        

Первая строчка определяет, подключена ли работа с компонентой обмена по FTP и включена ли работа по интервалу 2(период проверки связи при его отсутствии), следующая функция «ПрошелИнтервал1()» возвращает 1 в случае если прошел период со времени последней удачной отправки данных на FTP, 0 в случае неудачи, код функции ниже:

Функция ПрошелИнтервал1()
	ТекВрем = ТекущееВремя();
	//проверка времени!
	Если Константа.РаботаПоИнтервалу_2>0 Тогда
		Дельта = Константа.Интервал2ФТП; 
	Иначе
		Дельта = Константа.Интервал1ФТП; 
	КонецЕсли;                           	
	ПрошВремя = Константа.УдачноеВремяОтправки;
	СекТекущие = РасчетСекундПоВремени(ТекВрем);
	СекПоследние = РасчетСекундПоВремени(ПрошВремя);

	РазницаСекунд = СекТекущие-СекПоследние;
	Если (РазницаСекунд<0) Тогда
		РазницаСекунд=-РазницаСекунд;
	КонецЕсли;
	
	Если (РазницаСекунд>=Дельта) Тогда //*60
		Возврат 1;
	КонецЕсли;
	Возврат 0;
КонецФункции	 

Далее устанавливаем каталог FTP, и смотрим есть ли не отправленные файлы, если есть, то подключаемся при помощи функции «ПодключитьсяКFTP»

Функция ПодключитьсяКFTP()
	ОтключитьсяОтFTP();
	Подключено = 0;
	FTP.ИспользоватьПрокси		= 0; 
	FTP.ВремяДоРазрыва 			= 10000; 	
	FTPПассивныйРежим=0;
	Если FTP.Подключиться( СокрЛП(Константа.ИмяСервераФТП),
						Константа.ПортФТП,
						СокрЛП(Константа.ИмяПользователяФТП),
						СокрЛП(Константа.ПарольПользователяФТП),FTPПассивныйРежим)=0 тогда
		Сообщить("Не смогли подключиться к FTP-серверу");
	Иначе
		Подключено = 1;
	КонецЕсли;
	Возврат Подключено;
КонецФункции

После удачно подключения, выгрузим файл на FTP с помощью функции «ВыгрузитьнаFTP»:

Функция ВыгрузитьНаFTP(ОтправляемыйФайл,ВыбрФайл)
		Если FTP.ОтправитьФайл(ОтправляемыйФайл,ВыбрФайл)=0 тогда
			Предупреждение("Ошибка!!! Файл не отправлен!");
			Возврат 0;
		КонецЕсли;
		Возврат 1;
		
		НомерНезанятого = СоздатьСоединениеДляПотока(); 
		ТекКаталог="/";
		Если НомерНезанятого = 0 Тогда
			Возврат 0;
		КонецЕсли;
		
		
		Если FTPThreads[НомерНезанятого].ОтправитьФайлы(ОтправляемыйФайл,               // Файл(ы), расположенный на ftp
		                                               ?(СокрЛП(ТекКаталог)="/","",СокрЛП(ТекКаталог)), // Каталог на диске, куда будет записываться файл
													   0,                       // 1 - докачка разрешена, 0 - переписываем, даже если найдем с таким же именем
													   0,                       // 1 - удаляем после удачного принятия, 0 - не удаляем
													   1,                       // 1 - посылаем команду Отключиться() после получения, 0 - оставляем сединение с FTP
													   1                        // 1 - выполняем в потоке, 0 - без потока
													   )<> -100 Тогда
			Предупреждение("Произошла непредвиденная ошибка!");
			FTPThreads[НомерНезанятого] = "";
			Возврат 0;
		КонецЕсли;
		ИДПотока[НомерНезанятого] = FTPThreads[НомерНезанятого].ИДПотока();
		СостояниеПотока[НомерНезанятого] = "ОТПРАВКА";
		Сообщить("Номер потока = "+ИДПотока[НомерНезанятого]);
		
	Возврат 1;
КонецФункции

Описание функции «СоздатьСоединениеДляПотока»:

Функция СоздатьСоединениеДляПотока()
	НомерНезанятого = 0;
	Для й = 1 по 3 Цикл		
		Если ТипЗначенияСтр(FTPThreads[й])="Строка" Тогда
			НомерНезанятого = й;
			Прервать;
		Иначе
			Если FTPThreads[й].ВПотоке()=0 Тогда
				FTPThreads[й] = "";
				НомерНезанятого = й;
				Прервать;
			КонецЕсли;
		КонецЕсли;		
	КонецЦикла;	
	Если НомерНезанятого = 0 Тогда
		Предупреждение("Все потоки заняты");
		Возврат 0;
	КонецЕсли;
	FTPThreads[НомерНезанятого] = СоздатьОбъект("AddIn.FTP");
	FTPThreads[НомерНезанятого].ИмяЛогФайла = КаталогИБ()+"dialmail_ftp"+СокрЛП(НомерНезанятого)+".log";
	FTPThreads[НомерНезанятого].ВестиЛогФайл = 1;
	FTPThreads[НомерНезанятого].ВестиТехническийЛогФайл = 1;
	
	FTPThreads[НомерНезанятого].ВремяДоРазрыва	= 100000; // Timeout
	FTPThreads[НомерНезанятого].ВремяМеждуСобытиями=1000;		FTPThreads[НомерНезанятого].ИспользоватьПрокси=0; 
	FTPПассивныйРежим = 0;
	Если FTPThreads[НомерНезанятого].Подключиться(СокрЛП(Константа.ИмяСервераФТП),
						Константа.ПортФТП,
						СокрЛП(Константа.ИмяПользователяФТП),
						СокрЛП(Константа.ПарольПользователяФТП),FTPПассивныйРежим)=0 тогда
	
		Сообщить("Не; смогли подключиться к FTP-серверу");
		Возврат 0;
	КонецЕсли;
	Возврат НомерНезанятого;
КонецФункции

Затем отключимся от FTP:

Процедура ОтключитьсяОтFTP()

                FTP.Отключиться();

КонецПроцедуры

Теперь опишем обмен файлов в рабочем режиме. Создадим процедуру, которая будет выгружать чек после каждого закрытия чека «ВыгрузитьОтчетПоЧеку»:

	Процедура ВыгрузитьОтчетПоЧеку(ТекЧек) Экспорт 
		Для й=1 по 3 Цикл
			FTPThreads[й] = "";
			ИДПотока[й] = 0;
			СостояниеПотока[й] = "";
		КонецЦикла;
		//ИмяПК.PROD.№ЧЕКА.ДАТА
		ИмяЧека = ИмяКомпьютера()+"_"+"PROD_"+"№"+НомерЧека+"_"+СтрЗаменить(Строка(ТекущаяДата()),".","_");
		ИмяТекстовогоФайла = КаталогFTP+"\"+ИмяЧека;
		////Пошел процесс формирования 
		//Информация в файле: время чека, общая сумма чека, код товара, количество товара по коду, цена
		//-1-Создали файл
		Анализатор=СоздатьОбъект("AddIn.XMLParser");
		ФайлXML=Анализатор.СоздатьДокумент();
		
		ВыгрузкаXML	= Анализатор.СоздатьДокумент();
		Шапка		= ВыгрузкаXML.СоздатьПодчиненныйЭлемент("Chek");
		
		//Дата
		ствол = Шапка.СоздатьПодчиненныйЭлемент("Data"); 
		ствол.Значение = Строка(ТекущаяДата());
		//Общая сумма                          
		ствол = Шапка.СоздатьПодчиненныйЭлемент("Summ"); 
		ствол.Значение = ТекЧек.Итог("Сумма");	
		//Перебор!                                                  
		Тело		= Шапка.СоздатьПодчиненныйЭлемент("ChekStr");
		инд=0; 
		ТекЧек.ВыбратьСтроки();
		Пока ТекЧек.ПолучитьСтроку() = 1 Цикл
			инд = инд +1;
			Состояние ("Обработано "+инд+" элементов.");
			ЗаполнитьДанныеПо__(Тело,ТекЧек);	
		КонецЦикла;
		ВыгрузкаXML.Записать(ИмяТекстовогоФайла);
		//-1-2
		Если ПрошелИнтервал1()=1 Тогда 
			//Поиск не отправленных Файлов 
			ФС.УстТекКаталог(КаталогFTP);
			ИмяФайла = ФС.НайтиПервыйФайл("*.*");    
			Пока 1=1 Цикл                            
				ИмяФайла = ФС.НайтиСледующийФайл(); 
				Если ПустаяСтрока(ИмяФайла)=1 Тогда
					Прервать;
				КонецЕсли;
				Если (ИмяФайла=".") или (ИмяФайла="..") Тогда
					Продолжить;
				КонецЕсли;
				//-2-  Отправить по FTP  
				Если ПодключитьсяКFTP()=0 Тогда
					//включение интервала 2 
					Константа.РаботаПоИнтервалу_2 = 1;
					Прервать;
				Иначе 
					Если ВыгрузитьНаFTP(КаталогFTP+"\"+ИмяФайла,ИмяФайла)=0 Тогда
						//включение интервала 2 
						Константа.РаботаПоИнтервалу_2 = 1;
						Прервать;
					Иначе
						Константа.УдачноеВремяОтправки	= ТекущееВремя();
						Константа.РаботаПоИнтервалу_2 = 0;	
						//Переименовать!
						ИмяКуда = СтрЗаменить(КаталогFTP+"\"+ИмяФайла,"PROD","OTPR");
						ФС.ПереименоватьФайл(КаталогFTP+"\"+ИмяФайла,ИмяКуда,1);
					КонецЕсли;
				КонецЕсли;
			КонецЦикла; 
			ОтключитьсяОтFTP();
		КонецЕсли;
	КонецПроцедуры

           

Процедуру «ВыгрузитьОтчетПоЧеку» можно вызвать во функции «Выгрузка отчета» при следующих параметрах:

Если Константа.СпособОбменаДанными=2 Тогда

Смещение=0,

Синхронизация=1

Данные по чеку можно получить через

Если ФормаРегистрации<>0 Тогда

_Чек = ФормаРегистрации.Чек

Функция, которая создает xml-тело файл по данным чека «ЗаполнитьДанныеПо__»:

Функция ЗаполнитьДанныеПо__(Элемент,Эл) 
	ствол = Элемент.СоздатьПодчиненныйЭлемент("stroka"); 
	//Код товара
	Code = ствол.СоздатьПодчиненныйЭлемент("Code"); 
	Code.Значение = Эл.Товар.Код;
	//Кол
	Quantity = ствол.СоздатьПодчиненныйЭлемент("Quantity"); 
	Quantity.Значение =Эл.Количество;
	//цена
	Price = ствол.СоздатьПодчиненныйЭлемент("Price"); 
	Price.Значение = Эл.Цена;
	
	Возврат Элемент;
КонецФункции

В глобальном модуле сделаем следующие переменные

Перем КаталогFTP Экспорт;

Перем FTP Экспорт;

Перем FTPThreads[3];

Перем СостояниеПотока[3];

Перем ИДПотока[3];

Система готова. 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Vortigaunt 82 12.05.20 13:14 Сейчас в теме
Компонента dialmail удачный выбор. Нужно только упомянуть, что она не умеет в русские буквы в имени каталогов на ФТП. Ну или я не умею ее готовить. У меня почему-то при попытке создания каталога с русскими буквами создается каталог с какой-то кракозяброй. До этого пользовался компонентой из поставки АгентПлюс, но она очень тормозная. Медленно передает файлы на ФТП.
3. Ignatov_mu 32 13.05.20 10:19 Сейчас в теме
(1) Я использовал только латиницу, чтобы избежать проблем с кириллицей.
2. CheBurator 3421 12.05.20 22:55 Сейчас в теме
я гонял туда-сюда используя ncftp
Ignatov_mu; +1 Ответить
4. lame 54 14.05.20 07:58 Сейчас в теме
эта компонента у меня не захотела работать на винсервер2010
5. Ignatov_mu 32 15.05.20 09:37 Сейчас в теме
(4)А как компоненту зарегистрировали?
6. lame 54 15.05.20 09:50 Сейчас в теме
стандартно -Regsvr32 под правами администратора.

там через раз идет срабатывание
обращался к разработчкиам - они сказали - что на вин2010 она стабильно не работает и предложили поменять ОС
они об этой проблеме типа знают - но решения нет
7. Ignatov_mu 32 18.05.20 18:16 Сейчас в теме
(6)Если разработчики советуют, то без вариантов.
Оставьте свое сообщение

См. также

Клонируем объекты в стороннюю базу 7.7 DBF Промо

1С7.7<->1C7.7 v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free)

Клонируем объекты в идентичную по структуре БД.

16.12.2011    29367    11    Ёпрст    13    

Оптимизация выгрузки из 1С 7.7 по правилам обмена большого объема данных

Перенос данных из 1С7.7 в 1C8.X Обмен через XML 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

При выгрузке из 1С 7.7. большого справочника программа завершалась примерно с таким сообщением: "msxml6.dll: Недостаточно памяти для завершения операции". Вариант выгрузки порциями меня не устраивал. Поэтому немного оптимизировал обработку выгрузки. Возможно кому-то сэкономит время.

24.09.2014    31280    0    Just4Fun    29    

КД 2.0. Перенос документов 7.7 - 7.7. Передача параметра "Проведен"

Обмен через XML 1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md КД Бесплатно (free)

1С:Конвертация данных 2.0. Решение проблемы проведения документов при переносе между базами 7.7

20.12.2011    18224    0    xazrad    18    

Синхронизация справочников из внешнего файла dbf

Обработка справочников Файловые протоколы обмена, FTP v77::ОУ v77::БУ v77::Расчет 1cv7.md Бесплатно (free)

Обработка для синхронизации справочников из внешнего файла типа dbf.

05.07.2011    11787    0    uus    3    

1sqlite Промо

Внешние источники данных Разработка внешних компонент Файловые протоколы обмена, FTP v77::ОУ v77::БУ v77::Расчет 1cv7.md Бесплатно (free)

Внешняя компонента для работы с базами данных SQLite, плюс прямые запросы в ДБФ-базах 1С.

23.06.2008    55550    0    orefkov    290    

Перенос данных по сотрудникам из Бухгалтерии (хозрасчетной) в Зарплату и кадры (OLE)(7.7)

Обработка справочников 1С7.7<->1C7.7 Управление персоналом (HRM) Управление персоналом (HRM) v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК БУ Бесплатно (free)

Обработка предназначена для переноса реквизитов справочника сотрудника и зависимых с ним из бухгалтерии. Запускается из Зарплаты и Кадров.

03.02.2011    9604    0    Fanis    5    

Конвертация данных 2 - Отмена проведения документов в 7.7 при повторной загрузке

1С7.7<->1C7.7 Обработка документов v7.7 1cv7.md КД Бесплатно (free)

При повторной загрузке данных в 1С бывает необходимо отменить проведение у существующих документов.

21.10.2010    18557    0    nicxxx    7    

Помощь при работе с xBase (1С 7.7)

Файловые протоколы обмена, FTP Инструментарий разработчика v7.7 1cv7.md Бесплатно (free)

Утилита пригодится, если есть dbf-файл, но нет описания к нему. Также уменьшит ручную работу.

20.10.2010    14503    0    Hryv    12    

Мьютексы в 1С 7.7

Файловые протоколы обмена, FTP Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Бесплатно (free)

Существует ряд задач, которые требуют строго последовательного исполнения. Чаще всего это возникает при многопоточном программировании, в этом случае используются критические секции, но иногда надо синхронизировать и разные приложения - для этого существуют такие объекты ядра операционной системы как Мьютекс-ы. http://ru.wikipedia.org/wiki/Мьютекс В статье рассказывается как можно сделать аналогичный объект средствами 1С v7.7

02.07.2010    13910    0    Sk0rp    24    

Универсальная выгрузка/загрузка таблицы значений в dbf файл

Файловые протоколы обмена, FTP v7.7 1cv7.md Бесплатно (free)

Обработка выгрузки и загрузки ТЗ в dbf

20.05.2010    15041    0    xronos    7    

Подключение через OLE к базе 1С 77 из 1С 77

Практика программирования 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Пример подключения через OLE к базе 1С 77 из 1С 77

07.05.2010    9840    0    ildareshka    6    

Обработка "Заявка на перечисление ЗП" в Сбербанк в формате DBF

Универсальные печатные формы Файловые протоколы обмена, FTP Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v77::Расчет 1С7:ЗиК Бесплатно (free)

Еще одна внешняя обработка по подготовке DBF-файла и печатной формы "Заявки на перечисление ЗП в Сбербанк". Выполняется автоматический или ручной подбор еще не отправленных ведомостей выплаты ЗП через банк.

15.01.2010    14591    0    BorisBelov    7    

Переброска из ТиС в Бухгалтерию 7.7

1С7.7<->1C7.7 Оптовая торговля Оптовая торговля v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Бесплатно (free)

Переброска документов прихода, расхода, выписок, ПКО и РКО. Для программистов свободного распространения, желательно не в Пензе :). Проверено и доработано многократно. Версия 5.2 (исправлено совпадение элементов и групп справочников по наименованию)

09.09.2009    9148    0    fisgen    18    

1С 7.7. Внешние отчеты: еще один "Клиент-Банк"

Обмен с банком Обработка документов Банковские операции Файловые протоколы обмена, FTP Банковские операции v77::БУ 1С7:Бух Украина БУ Бесплатно (free)

Наглядно и много автоматизации, ничего лишнего. Для конфигурации 1С Бух Учет 7.7 для Украины

31.07.2009    13013    0    1cjob2007    5    

Перенос данных из ТиС в УСН

Обмен через XML 1С7.7<->1C7.7 Розничная торговля Розничная торговля v7.7 1С7:ТиС Россия БУ НУ ЕНВД Бесплатно (free)

Доработаны правила переноса для документов Реализация (розница) и Поступление ТМЦ (Розница).

22.07.2009    23983    0    bb1962    8    

Формирование остатков 2

Бухгалтерские 1С7.7<->1C7.7 v77::БУ 1С7:Бух Россия Бесплатно (free)

Обработка выполняет расчет остатков по выбранным счетам и формирует операцию с остатками. Есть возможность выгрузки по OLE.

31.05.2009    9668    0    int18h    6    

Загрузка правил обмена в КД 1.0

Обмен через XML 1С7.7<->1C7.7 Инструментарий разработчика v7.7 КД Бесплатно (free)

Обработка позволяет загрузить правила конвертации, сформированные в конфигурации Конвертация Данных 1.0 обратно в конфигурацию

27.05.2009    13846    0    Ctrl P    14    

Анализатор изменений:Справочники

Анализ учета 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Обработка позволяет сравнить справочники в идентичных базах (например у архивной и актуальной копии).

27.04.2009    7902    0    petro_fm    2    

[Сервер событий] Клиент + Сервер + Внешние события

Разработка внешних компонент Перенос данных из 1C8 в 1C8 1С7.7<->1C7.7 v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Средство для генерирования событий между разными сеансами, базами и платформами 1С

17.03.2009    19708    0    Душелов    32    

Перенос структуры справочника "Номенклатуры" из ТиС в БП 4.5

Обработка справочников 1С7.7<->1C7.7 v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Бесплатно (free)

Обработка предназначена для переноса структуры справочника "Номенклатура " из ТиС в Бухгалтерию предприятия 4.5.

17.03.2009    14192    0    arr    2    

Импорт для всех конф семерки!

Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Переносит любые справочники, документы и т.д. Работаю с ней уже год - все отлично при любом количестве строк.

06.02.2009    15332    0    floraukraine    21    

Перенос документов из ТИС 9.2 в Бух 4.5

1С7.7<->1C7.7 v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Бесплатно (free)

Обработка выгружает документы из ТИС в xml, а другая загружает из xml в БУХ.

22.01.2009    21573    1    newbas    22    

Универсальная обработка: Выгрузка и загрузка справочников с фильтрацией

Обработка справочников 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Универсальная обработка: Выгрузка и загрузка справочников с фильтрацией. Есть вариант с библиотекой V7PLUS.DLL, который не требует прав администратора, что делает данную обработку максимально независимой.

16.01.2009    11216    0    nikolka75    9    

Переброска документов "Выплата заработной платы" из ЗиК в Бух (1С 7.7)

Обработка документов Обмен через XML 1С7.7<->1C7.7 Зарплата Зарплата v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Бесплатно (free)

Обработка для выгрузки документов "Выплата заработной платы" из базы конфигурации "1С:Зарплата+Кадры" и загрузки в базу "1С:Бухгалтерия".

30.12.2008    15189    0    o.nikolaev    14    

Перенос данных из Бухгалтерии в 1С Предприниматель

1С7.7<->1C7.7 Обработка документов v77::ОУ v77::БУ 1С7:Бух Россия БУ Бесплатно (free)

Обработка необходима для ИП, находящихся на общей системе налогообложения и ведущих учет в типовой Бухгалтерии

05.12.2008    10431    0    Лев    19    

Импорт номенклатуры с штрихкодом (с проверкой уникальности штрих кода)

Обработка справочников 1С7.7<->1C7.7 Учет ТМЦ Учет ТМЦ v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Импорт номенклатуры из файла со штрихкодом (с проверкой уникальности ШК). Переделано из типовой обработки. Просто установите соответствие Базовая единица -> Штрихкод.

21.11.2008    12353    0    oncle_mic    4    

Перенос по OLE справочников однотипных конфигураций (для 7.7)

Обработка справочников 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Обработка переносит по OLE справочники со всеми подчиненными со всеми типами реквизитов (справочник, перечисление, число, дата, строка). конфигурации должны быть идентичны хотя бы в той части, которую копируем.

14.11.2008    7897    0    shavkat_95@mail.ru    9    

Перенос объектов между одинаковыми конфигурациями

Обработка документов Обработка справочников 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Еще один вариант переноса данных между базами 7.7 по OLE. Отличиями от аналогов является практически полное отсутствие настроек и модульный принцип реализации.

05.11.2008    24281    0    ValeriVP    27    

"Чат для 1С" - ActiveX-компонента для 1С + Сервер (Консольный) [БЕТА-ВЕРСИЯ]

Работа с интерфейсом Перенос данных из 1C8 в 1C8 1С7.7<->1C7.7 v7.7 v8 1cv8.cf 1cv7.md Россия Бесплатно (free)

UDP чат для обмена сообщениями в локальной сети. Поддерживет многоканальность, команды, обмен 1С ссылками (с возможностью открытия). Не зависит от платформы 1С, в одном чате можно сидеть на разных платформах и разных конфигурациях или вообще без 1С.

02.10.2008    24221    0    Душелов    248    

ОЛЕ перенос

1С7.7<->1C7.7 Учет ОС и НМА Учет ТМЦ Учет ОС и НМА Учет ТМЦ v77::БУ 1С7:Бух Россия БУ Бесплатно (free)

В данном архиве находятся реальные (сразу оговорюсь "НЕ УНИВЕРСАЛЬНЫЕ" - настраивались под конкретную конфу) обработки по переносу ч/з ОЛЕ, которыми я пользовался при переходе на НПС в Бухгалтерию 4.25 из одной из старых конф по бухгалтерии.

31.08.2008    11043    0    kotov    6    

OLE в 1С-Предприятии

Математика и алгоритмы 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Небольшая инструкция с примерами - как работать с OLE

09.08.2008    32418    0    Minotavrik    8    

(OLE 1С - 1C 7.7) Функции для 1С:Предприятие 7.7 для работы с другой базой 1С.

1С7.7<->1C7.7 Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Простенькие учебные функции (с описанием) для работы с базой 1С 7.7 через OLE. Полностью средствами 1С, т.е. не требуют никаких внешних компонент. Пользоваться можно бесплатно:-) Вставляете в глобальный модуль и пользуетесь. Цель: обучение, готовая иллюстрация подходов, возможность сразу использовать или, если нужно, доработать под свои цели.

06.08.2008    28671    0    venger    8    

Выгрузка начислений в файл DBF

Файловые протоколы обмена, FTP Обработка документов Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Выгрузка начислений в файл DBF, имеющий структуру, согласно требованиям одного из отделений СБ РФ.

14.07.2008    11360    0    йцук    9    

Экспорт платежек из 1С в .dbf файл для клиент-банка

Обмен с банком Обработка документов Файловые протоколы обмена, FTP Банковские операции Банковские операции v77::ОУ v77::БУ v77::Расчет 1С7:Комплекс Россия Бесплатно (free)

Экспорт платежек из 1С в .dbf файл для клиент-банка Sberbank (Западно-Уральский Банк Сбербанка России). Работает. После формирования файла в программе клиент-банк достаточно нажать "ИМПОРТ" и платежки уже там. -=Не забываем плюсовать, дамы и господа!=-

14.07.2008    18438    0    andrybar    9    

1С:Конвертация данных: Способ переноса дерева элементов справочников между разнородными конфигурациями.

Математика и алгоритмы Обмен через XML 1С7.7<->1C7.7 v7.7 1cv7.md КД Бесплатно (free)

Данная задача возникает когда необходимо перенести справочники между конфигурациями у которых различается количество уровней. Например, количество уровней в справочнике "Номенклатура" в конфигурации "Торговля и Склад" - 5, а в конфигурации "Бухгалтерия" - 4. Самое простое решение - отбросить реквизит "Родитель" элементов справочника при выгрузке, но есть способ элегантнее. В данном случае мы не обсуждаем возможность изменения структуры справочника в базе-приемнике конфигурации "1С:Бухгалтерия".

23.06.2008    12930    0    api.vl    2    

Загрузка любых справочников 7.7

Обработка справочников Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel v7.7 1cv7.md БУ Бесплатно (free)

Универсальная загрузка справочников 7.7 из xls, dbf, txt доработана для загрузки справочников, в которых реквизитом является счет из плана счетов

03.06.2008    10723    0    ge_ni    4    

Функция загрузки из DBF-файлов

Файловые протоколы обмена, FTP Практика программирования v7.7 1cv7.md Бесплатно (free)

Часто приходится что-то загружать из DBF-файлов и для того, чтобы не вспоминать каждый раз, как и что, сделал универсальную функцию загрузки DBF-файла в ТаблицуЗначений.

24.05.2008    18810    0    fAngel    13    

Импорт из Зарплата: Камин 1.2 в ЗиК 2.3

Обработка документов Обмен через XML 1С7.7<->1C7.7 Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Перенос данных из конфигурации "Зарплата: Камин 1.2" в конфигурацию "1С:Зарплата и Кадры" в случае перехода на использование другой конфигурации.

13.05.2008    20664    0    victuan    35    

Блок управления выгрузкой-загрузкой элементов справочников

Обработка справочников 1С7.7<->1C7.7 v7.7 1cv7.md Бесплатно (free)

Осуществляет перенос элементов в заданном диапазоне кодов.

27.04.2008    13085    0    Delon    6